[Решено] Пропало меню "Анализ данных" и инструменты

Здесь нужно сообщать об ошибках в QGIS, с подробным описанием шагов и версии ПО.
Ответить
jorra
Новоприбывший
Сообщения: 7
Зарегистрирован: 29 июл 2016, 21:54
Репутация: 2
Откуда: Томск-на-Томи
Контактная информация:

[Решено] Пропало меню "Анализ данных" и инструменты

Сообщение jorra » 09 янв 2017, 14:31

QGIS 2.18 (Windows XP)

Проблема успешно решена самостоятельно, но всётаки напишу, т.к. на русском Гугель мало полезного смог выдать, англоязычные советы не сильно помогли, а на этом форуме данную проблему и вовсе никто не поднимал, как видно.
Поэтому надеюсь, что кому-нибудь мой опыт пригодится, особенно новичкам и неспециалистам, вроде меня самого ;)

Проблема:
1) Завис инструмент smooth, вырубил QGIS через диспетчер задач.
2) После запуска – пропали почти все инструменты из пункта Вектор, пропал сам пункт меню Анализ данных.
3) Сброс настроек не помог.
4) Переустановка (с очисткой \Documents and settings\User\.qgis2) не помогла.

Решение:
1) Меню Установки => Параметры => Система => Текущие переменные среды.
Пробежался по списку, кое-где в путях к папкам и файлам оказалось, стояли неправильные (прямые /, а не обратные \, как в винде) слэши. Поправил вручную.
Перезапустил.
2) При запуске стало быстро выскакивать сообщение об ошибке. Со второго раза разглядел, что типа «Модуль processing при прошлом запуске повёл себя нехорошо, привёл к ошибке и поэтому был на всякий случай отключен».
Что ж, Модули => Управление модулями…, ищем нужный. В списке помечен шестерёнкой и поле для галочки рядом. Ставим галочку.
Всё.

Вроде, работает…

Ответить

Вернуться в «Ошибки QGIS»