Надежный формат для Dump для транспортировки и инсталлятора

Ответить
glax2020
Активный участник
Сообщения: 171
Зарегистрирован: 19 ноя 2012, 15:59
Репутация: 6

Надежный формат для Dump для транспортировки и инсталлятора

Сообщение glax2020 » 28 окт 2016, 17:39

Всех приветствую!

Не понимаю пока, как быть с Dump базы данных при транспортировки Dump.

Если я делаю для себя, то устанавливаю, скажем на работе ту версию PostgreSQL что у меня дома, и делаю на ней Dump для любой версии РоstreSQL, которая доступна мне по локальной сети, и проблема решена.

Но если, к примеру инсталлятор программы и Dump надо перевозить, то возникает для меня непонятная проблема - как быть?

Если у пользователя не будет никакой версии РоstreSQL на компьютере Windows - проблемы нет, мы ему устанавливаем свой нужный РоstreSQL под Dump, а если есть, то как быть?

К примеру, у меня (PostgreSQL 9.4.1, compiled by Visual C++ build 1800, 32-bit), а у пользователя на компьютере окажется другая версия или другая сборка - более ранняя, или более поздняя. То как быть в этом случае?

Спасибо

С ув. Александр

Аватара пользователя
jerry-maori
Гуру
Сообщения: 567
Зарегистрирован: 22 авг 2012, 17:02
Репутация: 134
Откуда: Нижний Новгород

Re: Надежный формат для Dump для транспортировки и инсталлят

Сообщение jerry-maori » 28 окт 2016, 18:10

1. написать в требованиях "PostgreSQL 9.4.1, compiled by Visual C++ build 1800, 32-bit"!
2. не использовать в БД любых version-specific вещей
3. написать конвертер, который будет из вашей БД делать ту, которая гарантированно развернётся на той версии БД, которая установлена у клиента

Перевозить Dump лучше в спец.таре (чтобы не разбился). Но, скорее всего, типовой вариант tar.gz архива подойдёт.

glax2020
Активный участник
Сообщения: 171
Зарегистрирован: 19 ноя 2012, 15:59
Репутация: 6

Re: Надежный формат для Dump для транспортировки и инсталлят

Сообщение glax2020 » 28 окт 2016, 19:40

Боюсь, если ситуация такова, то это слишком сложные требования для их выполнения для меня -- базу данных веду не только я и не столько я, собственно я в основном выступаю здесь как программист базы данных.

Боюсь, что мое предложения -- если у пользователя нет "PostgreSQL 9.4.1, compiled by Visual C++ build 1800, 32-bit"-- то ему будет необходимо его поставить, и мы ему поможем -- а все остальное -- под его личную ответственность...

Ariki
Гуру
Сообщения: 730
Зарегистрирован: 12 янв 2011, 22:40
Проекты: 1
Репутация: 303
Ваше звание:

Re: Надежный формат для Dump для транспортировки и инсталлят

Сообщение Ariki » 29 окт 2016, 17:33

Вот сколько используем PostgreSQL, не помню, чтобы хоть раз возникали какие-то проблемы при переносе дампа со старой версии на новую. Да и обратно тоже, если не использовать обратно несовместимых возможностей. Хотя у половины наших разработчиков Windows, у половины Linux и полный зоопарк версий PostgreSQL 9.x. На продакшне то же самое. И я думаю, что конфигурация PostgreSQL и флаги компиляции в большей степени влияют на совместимость, чем версия компилятора.

Другое дело — использование расширений, например, PostGIS. Там версия имеет значение, потому что процедуры в БД должны быть совместимы с бинарником. В случае с PostGIS использование postgis_restore.pl решает проблему восстановления на более поздних версиях.

glax2020
Активный участник
Сообщения: 171
Зарегистрирован: 19 ноя 2012, 15:59
Репутация: 6

Re: Надежный формат для Dump для транспортировки и инсталлят

Сообщение glax2020 » 29 окт 2016, 21:18

Спасибо, по изучаем.

Ответить

Вернуться в «PostGIS/PostgreSQL»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость