GEOL 4385 Spring 2009
Due: Tuesday, April 28

Lab 16
GRASS GIS

Geographic Resources Analysis Support System
(GRASS) is 3-D visualization software (FREEWARE)
package used for geospatial data management and
analysis, image processing, graphics/maps
production, and spatial modeling. GRASS is
currently used in academic and commercial
settings around the world, as well as by many
governmental agencies and environmental

consulting companies.

Originally developed by the U.S. Army Construction Engineering Research
Laboratory (USA-CERL, 1982-1995), a branch of the US Army Corp of Engineers,
as a tool for land management and environmental planning by the military,
GRASS has evolved into a powerful utility with a wide range of applications in
many different areas of scientific research. GRASS is currently used in academic
and commercial settings around the world, as well as many governmental
agencies including NASA, NOAA, USDA, DLR, CSIRO, the National Park Service,
the US. Census Bureau, USCS, and many environmental consulting companies.

* Free download: http://grass.itc.it/download/index.php
* Additional download site: http://www.kyngchaos.com/software:grass
> also follow link for Unix Compatibility Frameworks and download
these.
e For more info and help:
http://grass.itc.it/grass63/manuals/html63_user/

In this lab, you will learn how to import topography raster data, vector (points)
data, and display both in 3-D. You will be working with data that has been pre-
formatted for these types of applications - again, the SRTM (Shuttle Radar
Topography Mission) data, and has a resolution of 90 m. You will also be
downloading and formatting earthquake data from the USGS.
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Step 0.

You can work on either a Mac or PC for this lab. Depending on which
computer type you use, follow the setup instructions for running GRASS.

* Macs: Navigate to: Macintosh HD > Applications > GRASS
* Macs: drag-n-drop the GRASS icon desktop “dock”, where several other
icons are located at the bottom of your screen.

e PCs: Launch Cygwin, type startxwin.bat in the black window, then type
GRASS62 in the white window. (note: GRASS is not fully functioning on
the 409 PCs at this time, but will soon be).

Step 1. Example Exercise: Washington/Oregon Topography

1.1 Obtaining Topography data
You will first practice the steps of this lab exercise on an ascii data file that
contains the topography Washington and Oregon. Follow the following steps:

* Create a new Labl16 folder on your Desktop.

* From the Instructor/Labl6 folder, copy/paste the folder SRTM_dataset
to your Labl6 folder on your Desktop. This folder contains SRTM data
of the Washington/Oregon region, preserved in a folder structure suitable
for immediate GRASS import ( = someone did some pre-formatting of
data for you so that this lab wouldn’t take forever).

1.2 Opening GRASS DO E X| GRASS 6.4.0RC4 Startup

o Start GRASS as instructed
above. This will launch a
number of windows, including
one like the graphic (right). s S

. Welcome to GRASS GIS Version 6.4.0RC4
You may have to hit enter a The world's leading open source GIS
few times in a terminal Select an existing project location and mapset
. . or define a new location
window, if prompted.

GIS Data Directory: |/Users/Bridget/Desktop/Lablé Browse...
* In the GIS Data Directory =
. Project Location Accessible Mapsets Create new mapset in selected
pane[’ click on the Browse {projection/coordinate system)  (directories of GIS files) location
. SRTM_dataset " [PERMANENT h
button and navigate to your user
Lablé folder on  your
DeSktOp and CliCk OK Define new location with...

Georeferenced file
EPSG codes

Projection values

Enter GRASS Exit Help
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* Under Project Location, the folder SRTM_dataset should be listed, and
under Accessible Mapsets, two folders named PERMANENT and user

should be listed.

» Highlight the SRTM_dataset Project Location and then user Accessible

Mapset, then click the

window.

“Enter GRASS” button on the bottom of the

* You may have to wait a few seconds, but eventually 4 additional windows

will pop up:

1. GRASS6.3.0 GIS Manager

2. Map Display 1
3. Output
4

Terminal - bash: showing a prompt:
GRASS 6.4.0 (SRTM_dataset):>

and above it “GRASS GIS”

in ascii art.

The Output and Terminal windows show that GRASS has its original roots in a
command line set of programs (like UNIX), which the newer versions now call

through a graphical window.

) (X! GRASS6.4.0RC4 GIS Manager - SRTM_dataset user

File Confiy Raster \ector Imagery Volumes Databases Help

Ains
FEZELEED KA e g

e Ok )| DeW B2
Map Layers for Display 1

Welcome to GRASS GIS

N\ Map Display 1

I.Maﬁ hAQG QL BimE =,

Display: rows=292 columns=489 -125.642537 43.1776493

X/ Output - GIS.m

Save | Clear

Run (hackground) Run (GUI)

1

Terminal tcsh 78x24
PR Y I S R R A
Sl R R AL TR BT
PAG Ty s |___/ -t £ AT =
S ey I T CST 0 W

Welcome to GRASS 6.4.8RC4 (2009)
GRASS homepage :

This version running thru:

Help is available with the command:
See the licence terms with:

If required, restart the GUI with:
When ready to quit enter:

http://arass.osgeo.org/
TC Shell {/bin/tesh)
g.manual -i

g.version -c

g.gui teltk

exit

Mapset <user= in Location <SRTM_datasets
GRASS 6.4.8RC4 > [|
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Before the next step, it is understand a few main points about GRASS:
GRASS supports topography and other regularly spaced data as “rasters”
(Reminder: raster means that there is a data point every x meters or
degrees). For irregularly spaced data points (field locations, sample sites,
etc) and for actual vectors and ARC format shape files, GRASS uses a
“vector” format. In the SRTM_dataset folder, you are provided an existing
GRASS mapset with a raster topography file (45N125W.r) This data file
spans 5 degrees in both longitude and latitude, and has a name
corresponding to its lower-left corner of the grid (minimum west
longitude, minimum latitude).

What is the minimum longitude of this dataset?

What is the maximum longitude of this dataset?

What is the minimum latitude of this dataset?

What is the maximum latitude of this dataset?

In the GRASS GIS Manager window click on the second icon:

£

A window subset with data definition options should appear in the lower
half of the window:

Display raster maps
1.00
Opaque Transparent

Base map: ((; 45N125Y. r@user i 3

values to display

Optional color draping. Use hase map for shading,
drape map for color in color relief map or data fusion
drape map: ((;

drape map brightness adjustment 0o 3

e

W overlay maps from other layers (transparent null value cells)
Set background color {colored null value cells) v

Welcome to GRASS GIS

In the lower part of the window click on the button next to “Base map”
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and select the raster file: 45N125W.r
* Now you are ready to display your first topography image. Go to the
Map Display 1 window and click on the Display Active Layers button:

* Now the image will be rendered and should look something like the
graphic below.

* Notice that the bottom right part of the window shows the latitude and
longitude of the mouse (cursor) on the map. You can also zoom in and
out with the magnifying glass icon pan with the hand icon.

000 '\ Map Display 1

BEasH AQd QL

Bl @ 5 HE

Jisplay: rows=573 columns=579 resolution=0.00 -120.000436 45.017036
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* To change the colors of the map, in the GRASS GIS Manager window
click: > Raster > Manage map colors - Color tables

* A new window (r.colors) should open up. Under the “Colors” tab select
a table from the Type of color table drop-down menu (e.g. elevation,
etopo2, or srtm). For the example below, the table “srtm” was selected.

X/ r.colors
ga Creates/modifies the color table associated with a raster map layer.

Required | Options  Colors

_I Invert colors

I Logarithmic scaling

I Logarithmic-absolute scaling

_| Histogram equalization

Type of color table: {color: style, optional)

| st =
Path to rules file {("-" to read rules from stdin): (rules: name, optional)
=2
r.colors
Run | Help ‘ Close |

* Under the “Required” tab, click on the map icon and select 45N125W.r

X/ r.colors
(’J Creates/modifies the color table associated with a raster map layer.

Required | Options | Colors

Name of input raster map: (map: name, optional)

L
’3‘ 45N125V. reuser

| r.colors map=45N125W.r@user color=stm

Run | Help “ Close |

* Next click the “Run” button. An Output - GIS.m window should appear,
but your map probably won't be updated. For the map display to realize



GEOL 4385 Spring 2009
Due: Tuesday, April 28

this a change has been made (like color), you need to kill/close the Map
Display window and start a new Display window. To do this, in the
GRASS GIS Manager, click on the left-most icon:

* This will launch a new Map Display window. To re-display the
topography, repeat the steps beginning on page 4 (1/2 way down).

0600 [X| Map Display 2
EELsH :AQd AL Bk os D8

Display: rows=482 columns=642 resolution=0.0103734 degr [ -120.705827 45.134438 ]

* Next you will display this dataset in 3D. In the Map Display, window
press the “Start NVIZ...” button:

ela

 This may take a little time to load, but eventually an NVIZ window will
open:
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X NVIZ

File Appearance Visualize Scripting Help

DR&W Clear Cancel
Automatically render display: &

Show features:  Main features... Decorations...
View method: & eye - center - flynone -
M
Look
here _
centar | Iw . E height z-exag
43715 0.0o0c
top i
[ ]
reset 3
perspective 40.0 twist 0.0

» Experiment with the menus and options provided. Change the “height” of
your data by changing the number to ten times as large (for example, if
it says 40000 make it 400000). Practice zooming in with the
“perspective” slider. Change the angle of view with the dot-and-arrow
in the N-E-S-W box. Change the vertical exaggeration (z-exag) to see
the topography better.

* To modify the resolution of the data, select

> Visualize > Raster Surfaces.

The “coarse” resolution is the resolution while you rotate the image, the
“fine” resolution is the resolution GRASS renders when you stop moving.
Number “1” will render at the best resolution (90 m of the dataset), but
this will take longer to render, and you probably wont see much of a
difference compared with a “5” at a zoomed-out view. Sometimes you
have to move the dot-and-arrow (angle of view) to make it render again
(or press clear and draw buttons near the left top).

» Background: If you dont like the white background and prefer black for
visualizations (as is used in most programs), select

- Appearance > Background Color
and click on the white square and change it to your favorite color.

* Shading: You can also change the direction of shading by selecting
- Appearance > Lighting
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This will bring up another angle of view for the direction of the
sun/lighting.

Step 2. Collecting data: Global Earthquakes

In a web browser, navigate to the USGS earthquake website:
http://earthquake.usgs.gov/eqcenter/

- Along the left column menu, click on Search EQ Database.

- Then click on Rectangular Area for your Search Area.

- Select Screen File Format (80 columns) as your Output File Type.

- Under Data Base, select the USGS/NEIC (PDE) 1973-Present Data Base.

- Enter the latitude/longitude coordinates that span your search region under
Input Rectangular Area Search Parameters. For the following example,
you should use the NW USA test region that spans our topograhy: top
latitude: 50, bottom latitude: 45, left longitude: -125, right longitude: -
120.

- Under Optional Search Parameters, enter a date range of seismicity that
you want to search. For example, to look for seismicity over the last 2
years, you'll enter: 2006/01/01 to 2008/01/01.

- Also under Optional Search Parameters, you can enter a range of
earthquake magnitudes that you want to search. For example, you CAN enter
3.0 and 50 as your minimum and maximum magnitudes if you want to
search these ranges of magnitudes.

- Leave the rest of the boxes blank and click the Submit Search button.

- Your data should appear on the next screen. You will have to determine if
your search criteria produce a significant data set - you may have to go
back and re-search the database for more events. Note that you can also
repeat this process to gather files of different data ranges. For example,
you can collect all of the magnitude 3-5 earthquakes in one data set.
Then collect magnitude 5-7 earthquakes in another.  You can also do this
for various date ranges. This is helpful if you want to highlight different
magnitudes in different colors/sizes.

- Select (highlight) and copy all of the column data from our web search
result. Then paste the data into a simple text editor:

PCs: Use the “Notepad” application. Notepad will save as a
*txt file.

Macs: Use the TextEdit application. When you save the file, select
the Rich Text Format (RTF).
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Save the file (name it earthquake_data) to your Labl6 folder on your Desktop.

Step 3. Importing data into Excel

Open Excel and a new blank spreadsheet should appear. To open the new file
you just created, click on File>Open. In your Open window, change the file
type option to “all files/documents™

PCs: Files of type - select “All Files (*.*¥) > select your text
file > Open
Macs: Office 2008: File > Import > Text File > Import >
Enable: All Files > select your text file > Get Data
or
Office 2004: Enable > select “All (Readable) Documents”
> select your text file > Open

Text Import Wizard - Step 1 of 3

The Text Wizard has determined that your data is Fixed Width.
If this is correct, choose Next, or choose the Data Type that best describes your data.
Original data type

Choose the file type that best describes your data:

() Delimited - Characters such as commas or tabs separate each field.
® Fixed width - Fields are aligned in columns with spaces between each field.
Start import at row: 9 1 File origin: | Macintosh ﬂ

Preview of file Macintosh HD:Users:Bridget:Desktop:Earthguakes.rtf.
9 _| PDE 2006 ©L @7 932124.18 32.49 -115.44 \
[10] PDE 2006 0L 07 004919.48 32.49 -115.44 \ D
[L1] PDE 2006 OL 09 151314.18 32.17 -115.88 ¢ \
2] PDE 2006 @L 13 233883 37.47 -118.78 11 3.1 N\
23| PDE 2086 @L 18 122805 33.22 -116.89 7 3.0 MLPAS .F. ....... N 4
[L4] PDE 2086 @L 22 102807 35.66 -119.19 25 3.8 MLPAS .F. ....... \ %
“a »
| r——r s
Cancel < Back ( Next> ) ( Finish )

You will next be greated by the “Text Import Wizard” screen. Follow the
instructions on the wizard’s screen to import your data in the Excel format.
Inspect all of the options presented to you in each Step of the Wizard, making
sure you understand how each operates. You may see some garbage text in
the Preview panel of the screen - this is okay for now, and you’ll get rid of it

10
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later, however scroll down to check that the rest of you data is in column
format.

When you encounter the select field breaks (column width) window (Step 2),
create breaks at every obvious column (by clicking), however group the date
(year/month/day) columns into one break, and select the appropriate format for
the date (Step 3). You can also skip importing the last few columns on the
right that appear useless (symbols, etc.). After completion of the Wizard steps,
you should have a series of columns with nicely organized data.

Text Import Wizard - Step 3 of 3

If you have any garbage text remaining in your worksheet, simply remove it by
highlighting the text and then go to Edit > Clear > AllL

4. Formatting the data (getting rid of the stuff you don’t
need)

Now you will delete all of the unnecessary data. All you eventually want to

end up with is a file with three columns:
Longitude Latitude Depth(meters).

11
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Below are highlighted columns that you'll want to delete (if you imported your
data correctly). To delete these, highlight them, then go to Edit > Clear >
All.

Latitude Longitude Depth (km)

vy v

< A B C D E F G |

1 |PDE 1/7/06 2124.1 32.49 -115.44 5 3.7 \
2 PDE 1/7/06 4919.4 32.49 -115.44 5 3.7 \
3 |PDE 1/9/06 151314.1 32.17 -115.8 9 3.2 \
4 PDE 1/13/06 233003 37.47 -118.78 11 3.1 \
5 PDE 1/18/06 122805 33.22 -116.09 7 3 \
6 |PDE 1/22/06 102807 35.66 -119.19 25 3 \
7 PDE 1/22/06 231852 32.33 -115.18 30 3 \
8 |PDE 1/26/06 230330 32.34 -115.14 9 3.3 \
9 |PDE 1/27/06 52245.5 32.35 -115.13 8 3.9 \
10 PDE 1/27/06 54402.8 32.33 -115.13 9 3.7 \
11 PDE 1/27/06 54928.6 32.34 -115.14 8 4.1 \
12 |PDE 1/27/06 65942.23 32.45 -115.27 5 3 \
13 |PDE 1/27/06 2258 32.35 -115.14 6 3.6 \
14 PDE 1/28/06 80532.4 32.39 -115.05 7 3.5 \
15 PDE 2/4/086 103234.7 32.36 -115.15 6 34 \
16 PDE 2/4/086 123832.2 32.37 -115.13 7 3.6 \
17 PDE 2/5/06 154333.95 34.24 -119.81 7 3.2 \
18 PDE 2/6/06 45539.29 35.82 -119.91 12 33 \
19 |PDE 2/7/086 101152 32.82 -115.7 16 3 \
20 PDE 2/7/06 182356.7 32.34 -115.21 9 3.9 \
21 |PDE 2/7/06 182712.9 32.35 -115.1 9 <] \
22 |PDE 2/8/06 200614.9 32.31 -115.11 14 o \
23 PDE 2/8/06 220446 32.28 -115.06 4 3.1 \
24 PDE 2/13/06 202152.5 32.21 -115.04 9 3 \
25 PDE 2/13/06 210557.89 32.12 -115.02 6 31 \
26 |PDE 2/14/06 104019 32.07 -115.81 2 31 \
27 |PDE 2/15/086 225642.8 32.07 -115.96 5 3 \

Next you'll need to convert the Depth column from km to meters, since the
topography uses elevation in meters. To do this, double click in the first cell of

the empty column next to your Depth column. Type “=" in the cell, then click
on the first entry of your depth column. Your empty “=" cell should fill with the
letter-column designation you just clicked in. Then click back in your “=" cell

and type “ *-1000 ”, to multiply the cell by 1000. Then hit Enter.  Your cell
should now represent your depth entry in meters. To repeat this process for
the rest of the cells in your column, click on the new cell that you just
converted and hover your mouse in the bottom right corner of the cell box.
When a “+” sign appears, hold down your mouse button and drag to the
bottom of the column. When you release the mouse, the remaining column
cells in your column should fill with the proper depth in meters.

Now you'll want to Copy = Paste your longitude column to the 1% available
column (labeled A). Then Copy = Paste your latitude column to the 2™
available column (labeled B). Then Copy > Paste Special (select the
Values button, then OK) your new (meters) depth column to the 3™ available
column (labeled C). If you have any remaining data, like your old depth (km)
column, just delete it.

12
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The first few rows of your final Excel sheet should look something like the
following:

< A B C D
1 -115.44 32.49 -5000
2 -115.44 32.49 -5000
3 -115.8 32.17 -8000
Bl -118.78 37.47 -11000
5 -116.09 33.22 -7000
6 -119.19 35.66 -25000
7 -115.18 32.33 -30000
8 -115.14 32.34 -2000
) -115.13 32.35 -8000
10 -115.13 32.33 -8000
11 -115.14 32.34 -8000
12 -115:27 32.45 -5000

13 -115.14 32.35 -6000

5. Saving the file

* To save your file, select File > Save As >

* On the “Save As” screen, look for the “Save as type” or “Format” option
and select “CSV (Comma delimited)”. The default suffix should be (*.csv).
Give your file a name (Earthquakes.csv) and click “Save”. Make sure to
save it in your Labl6 directory on your Desktop. NOTE: Excel will
probably warn you that saving in this format may ruin the file, just ignore
this and click yes (you are sure): there is nothing in this file that csv
cannot handle.

6. Importing into GRASS GIS

To import this dataset into GRASS, switch to GRASS and look for the terminal
window, which is the window with the GRASS GIS ascii art. This window should
have a prompt that looks like:

GRASS 6.3.0 (SRTM_grass):

First you will want to change to the working directory (Lab16):
s type: cd ~/Desktop/Labl6

Check for your file (Earthquakes.csv):
* type: Is

Make sure the region will import everything (a standard GRASS command):
* type: g.region -d

13
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Now for the importing:
* type: v.in.ascii -zn input=Earthquakes.csv output=Earthquakes
format=point fs=, z=3

The -zn flag above tells the import function that there will be a z-coordinate,
while the n tells it that the file does not have a header (text above the lat, lon,
depth) The format=point flag tells the import function that these are individual
points. The fs flag tells the import function that the columns are separated by

. The z=3 flag tells the import function that the z-coordinate is in the 3™
column

Overall, the import should be relatively quick, and CRASS will tell you that
v.in.ascii is complete.

» Before plotting you will first want to reset the region in GRASS to only
the raster you are interested in: For the example NW USA region:

 Type: g.region rast=45N125W.r

7. Plotting the events in GRASS GIS

GRASS does not update any parameters on the “Map Display” window, so close
an open Display windows.

« Now you want to start a new Map display, press in the GRASS GIS
Manager window:

& d
*i
* First display the topography:
* In the bottom half of the screen, select your raster file.
* To plot the earthquake locations: click on the add vector layer button
in the GRASS GIS Manager window, the add vector layer button:

™

* In the bottom half of the window, click on the button next to “Vector
Map:” Select the Earthquakes file and press OK. You can also change

14
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the type of symbols (“lcon” button) and the size (Size: 5). GRASS will
use in the plot.
* Finally, to complete theplot, go to the Map Display window and hit the

“Display active layers” button:
e

EELsHE "RAG QL Bimy @ 5| H|

To plot your earthquakes in 3-D, in the Map Display window press the “Start
NVIZ...” button:

e

15
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File appearance Yisualize Scripting Help

DRAYW Clear Cancel
Automatically render display: W

Show features:  Main features.. — | Decaorations.. -
View method: ¥ eve wo center - flynone -
M
Look.
here
center | W . E height z-exag
A 19224 71428
top .,
h)
reget 5
perspective 40.0 tuist 0.0

Adjust the features that you have used before to change exaggeration,
view angle, perspective, background color, etc. In addition, you can
adjust the earthquake symbols (they start out a little big) by clicking
Visualize > Vector Points.

Make the window bigger to see all the options (drag right-bottom corner).
To display the points properly, click on the “3D Points” button (instead
of “display on surface(s)”

Change the topography surface to transparent by clicking Visualize >
Raster surfaces. Then, under the “current” raster name click on the
“Surface attributes” pull-down menu, and select “Transparency”. This will
open up a window in which you click “New constant” and use a slider to
find a good number (try ~50, then play around). Click accept (twice) and
click “Draw current” in the very left-bottom to make the screen update
(you may have to do this more often, since the monitor doesn’t always
update the graphics).

16
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Help

DRAW Clear | Cancel |

Automatically render display: W

Show features:  Main features. . —-| Lecorations... —|
View method: ¥ oye w Centar  ~, flynone —
:h[’;-:l- B [
Look
here

N height z-Exag

center | W E s 2
_|1gzz4 0.000C
top ! :I

reset . s

| = | i
perspective 40.0 twist 0.0

Vector Points Panel

mrrent::f-eqs@jasperkonteg Mew | Delete |
ican size |D.DDE s icon type !sphere - -
# 3D points

~ display on surface(s): W 45M1Z5W.r@jasperkonter

_I thematic mapping for vector points

DRAW CURRENT | Close

8. Save your visualization

* To save your work, select File > Save Image as > TIFF IMAGE
e This will open up a box where you enter a filename (yournamelabl6.tif),
and save to your Labl6 folder. Make a copy of this image and drop it in

the DropBox
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