Не удалось загрузить модуль MetaSearch

Здесь нужно сообщать об ошибках в QGIS, с подробным описанием шагов и версии ПО.
Ответить
_taras_
Интересующийся
Сообщения: 38
Зарегистрирован: 28 июл 2018, 08:40
Репутация: 2
Откуда: Киев

Не удалось загрузить модуль MetaSearch

Сообщение _taras_ » 28 июл 2018, 08:48

Система: Убунта 18,04 64 битная
Версия Python:
2.7.12 (default, Dec 4 2017, 14:50:18)
[GCC 5.4.0 20160609]
Версия:
2.8.6-Wien Wien, exported
Модуль пробовал переустановить, но ошибка не пропала.

Код: Выделить всё

Не удалось загрузить модуль MetaSearch из-за ошибки при вызове его метода classFactory()

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/qgis/utils.py", line 219, in startPlugin
    plugins[packageName] = package.classFactory(iface)
  File "/home/taras/.qgis2/python/plugins/MetaSearch/__init__.py", line 29, in classFactory
    from MetaSearch.plugin import MetaSearchPlugin
  File "/usr/lib/python2.7/dist-packages/qgis/utils.py", line 478, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/home/taras/.qgis2/python/plugins/MetaSearch/plugin.py", line 28, in 
    from qgis.PyQt.QtCore import QCoreApplication
  File "/usr/lib/python2.7/dist-packages/qgis/utils.py", line 478, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
ImportError: No module named PyQt.QtCore
Путь поиска Python:

Код: Выделить всё

['/usr/share/qgis/python', u'/home/taras/.qgis2/python', u'/home/taras/.qgis2/python/plugins', '/usr/share/qgis/python/plugins', '/usr/lib/python2.7', '/usr/lib/python2.7/plat-x86_64-linux-gnu', '/usr/lib/python2.7/lib-tk', '/usr/lib/python2.7/lib-old', '/usr/lib/python2.7/lib-dynload', '/usr/local/lib/python2.7/dist-packages', '/usr/lib/python2.7/dist-packages', '/usr/lib/python2.7/dist-packages/PILcompat', '/usr/lib/python2.7/dist-packages/gtk-2.0', '/usr/lib/python2.7/dist-packages/wx-3.0-gtk2', u'/home/taras/.qgis2//python']
Так же не удается проверить версию Qgis пишет
"Неудалось получить информацию о версии с сервера"

gamm
Гуру
Сообщения: 2973
Зарегистрирован: 15 окт 2010, 08:33
Репутация: 691
Ваше звание: программист
Откуда: Казань

Re: Не удалось загрузить модуль MetaSearch

Сообщение gamm » 28 июл 2018, 09:08

_taras_ писал(а):
28 июл 2018, 08:48
No module named PyQt.QtCore
ответ на ваш вопрос ... а вот почему его нет, это уже другой вопрос :mrgreen:

для начала обновите QGSI ...

Ответить

Вернуться в «Ошибки QGIS»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость